WineHQ

SWAT 4

Retail versions from 1.0 to 1.1.

Application Details:

Version: 1.x
License: Retail
URL:  
Votes: 5
Latest Rating: Platinum
Latest Wine Version Tested: 4.19-staging

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Version: 1.1

The Game!!

What does not

installer maybe?


minor hicup in startup

Workarounds

What was not tested

installer

cd protection

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

my last post was wrong sorry, i was impatient and silly firstly, the error was because mesagl took over from nvidia gl in my 32bit chroot. but it did unearth some helpfull things. firstly. i just copied across swat4 from a windows machine and dropped it into my wine c_drive/program files. then set wine to windowed 800x600, with win98 (winecfg) (i tried winxp but it just sat there after pressing yes against the video error) with mesagl run the swat4.exe with wine, i got a video card error from swat 4 (which i previously thought was fatal - but still is a regression) time passed, infact during that time i submitted the previous post, then the game movies started (sound problems though - the console shows buffer underruns, i think due to cpu usage), the menu worked *perfectly* and the game seemed to work but very slowly, except the mouse wasnt grabbed in the window. the menus were all perfect and i didnt see any gfx errors. just choppy sound and low frame rate. i could change graphic settings without any problems. as it came from windows with 1280x1024 (which the wine window resized to) - i then turned it down to low detail 800x600. i could move around the training mission with 'a,w & d' keys - but as i said, the window didnt grab the mouse in the window. i didnt try full screen. soo it would seem that things have improved considerably! with nvidia gl no video card error the start movies ran much more smoothly and no choppy sound. the game menu worked properly (no silly mouse problms) but it had a white background (unlike in mesagl) in the training mission, when i looked at the floor it was ok, but looking up a bit gave a white screen, i moved around and the white screen would flash randomly with the floor etc. sound seemed okay. i could shoot etc. hit esc and the menu seemed to work fine. i could go change gfx settings and then go back into the game. (same white problems) so yeah, heaps of improvement. (note that i am using a no-cd fix)

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 19.10 "Eoan" (+ variants like Kubuntu)Nov 15 20194.19-stagingYes Yes NoPlatinumDavid Seward 
ShowDebian GNU/Linux 9.x "Stretch" x86_64Jun 05 20172.9Yes Yes SilverGero45 
ShowDebian GNU/Linux Unstable "Sid" x86_64May 01 20172.0.1Yes Yes SilverDavid 
ShowArch Linux x86_64Jan 03 20172.0-rc3Yes Yes GoldDJ 
ShowArch Linux x86_64Feb 18 20141.7.12Yes Yes Silveran anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

Quick Play

You can use the Lutris script if you don't want to go through the hassle of setting up your own Wine Prefix for the software. It assumes the GOG version, but I'm sure it works with any version.

Comments

Back