WineHQ

Imperium Galactica II: Alliances

The final "official" patch from infogrames. For best results please use 1.14 patch.


Application Details:

Version: 1.06
License:
URL:  
Votes: Marked as obsolete
Latest Rating: Silver
Latest Wine Version Tested: 1.1.15

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installation, game itself, almost all is fine. Game runs pretty fast. Update also

What does not

Crash in the fifth tutorial, crash within diplomacy or trade screens, due to bug linked below. Minor sound issues also exists.

Workarounds

What was not tested

Multiplayer

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Don't forget to update to version 1.06! Previous one is not working at all

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
CurrentopenSUSE 11.0Mar 20 20091.1.15Yes Yes Silveran anonymous user 
ShowUbuntu 8.04 "Hardy" i386 (+ variants like Kubuntu)Oct 22 20081.1.6Yes Yes Bronzean anonymous user 
ShowFedora 8May 03 20080.9.61.Yes Yes PlatinumHarpSeal1 
ShowUbuntu 7.10 "Gutsy" i386 (+ variants like Kubuntu)Apr 22 20080.9.59.Yes Yes PlatinumKelytha 
ShowopenSUSE 10.3Mar 29 20080.9.57.Yes No Garbagean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Doesn't work for me
by Daniel Koszta on Sunday May 25th 2008, 12:06
I tried it on Debian, installed wine-0.9.61 from source but it doesn't run at any reasonable speed.
The configure script didn't complain about dependencies except those needed for scanning, digital cameras and ISDN.
The installation of the game was OK, the intro movies also worked well, but when I got to the screen where I could choose what do I want to do (multiplayer / single player / tutorial / etc.) it got unreasonably slow.
Setting to low-quality didn't solve my problem.
My hardware is much more powerful, then the recommended in the readme.

I got the following messages in the terminal:

fixme:richedit:RichEditWndProc_common WM_STYLECHANGING: stub
fixme:richedit:RichEditWndProc_common WM_STYLECHANGED: stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f5f0,0x00000000), stub!
err:d3d:WineD3D_ChoosePixelFormat Can't find a suitable iPixelFormat
err:d3d:WineD3D_ChoosePixelFormat Can't find a suitable iPixelFormat
fixme:d3d:state_subpixel Render state WINED3DRS_SUBPIXEL not implemented yetfixme:d3d:state_stippledalpha Stippled Alpha not supported yet.
fixme:d3d7:IDirect3DImpl_7_EvictManagedTextures (0x1247d0): Stub!
fixme:d3d7:IDirect3DImpl_7_EvictManagedTextures (0x1247d0): Stub!
fixme:d3d7:IDirect3DImpl_7_EvictManagedTextures (0x1247d0): Stub!
fixme:winmm:MMDRV_Exit Closing while ll-driver open
fixme:d3d7:IDirect3DDeviceImpl_7_Release Material handle 1 not unset properly
SOLVED
by Daniel Koszta on Wednesday June 4th 2008, 16:14
Problem solved enabling direct rendering.
Sorry for not reading FAQ!
issues
by René on Sunday November 25th 2007, 23:56
the crash issues are very odd, because back on 0.9.3* i can remember playing IG2:A without any crashes for a long time.
but i cant remember wich wine version it was.

it was awesome because even windows couldn't run the game the way i wanted it to.^^
RE: issues
by René on Sunday December 2nd 2007, 15:59
as far as i could see the last working version is 1.0
Back