WineHQ

Xfire

This version apparently adds more robust networking support (e.g. UPnP and UDP port opening) as well as supports more games.

Application Details:

Version: 1.5x
License:
URL: http://www.xfire.com
Votes: Marked as obsolete
Latest Rating: Bronze
Latest Wine Version Tested: 0.9.17.

Maintainers: About Maintainership

No maintainers. Volunteer today!

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

installs, starts up, main screen minimizes, resizes and allows you full access to options and chatting (chatting works perfectly and you can get full information on other users by putting the cursor over their name)

What does not

main screen has cryptic user names

Workarounds

What was not tested

file transfer, joining servers

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

The problems stated before about it not minimizing correctly can be fixed by giving your window manager control over xfire. This also fixes chat windows wanting to be on top.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowFedora Core 5Aug 06 20060.9.17.Yes Yes BronzeMagicalHobo 
CurrentGentoo LinuxJul 27 20060.9.17.Yes Yes Silveran anonymous user 
ShowGentoo LinuxApr 30 20060.9.12.Yes Yes Silveran anonymous user 
ShowGentoo LinuxApr 23 20060.9.12.Yes No Garbagean anonymous user 
ShowGentoo LinuxApr 29 20060.9.8.Yes Yes Bronzean anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

HOWTO

Xfire depends on a few dlls that seem to be needed in the system32 folder (if you are emulating 2000 or higher)

cd ~/.wine/drive_c/windows/system32

ln -s /usr/lib/wine/msvcrt.dll.so msvcrt.dll

You also need to install 'fontforge' to read chat windows to at least version 20060408

(pre 0.9.12)

Run 'winecfg' and 'Add application' Xfire.exe. Now go to 'Libraries' tab -> 'New override for library:' -> 'd3d8' and add it to 'Existing overrides', useing 'Edit' change to 'disable' or 'native only' and Xfire wil run.

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back