WineHQ

SolidWorks

SolidWorks 2007

Application Details:

Version: 2007
License: Retail
URL: http://www.solidworks.com
Votes: 2
Latest Rating: Bronze
Latest Wine Version Tested: 1.1.22

Maintainers: About Maintainership

No maintainers. Volunteer today!

Free Download SW download

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Install without errors directly from the package.

Solidworks runs, all the toolbars are correctly drawn and I can create a new part/assembly

Display is Ok, no artifacts if background windows color is set to a solid color, not a bitmap (default). So change it in preferences !

Sketching works perfectly.

All the 3D operations works, except extrude (very annoying ! ).

Rebuild of existing parts works perfectly, even in extrude functions

What does not

Everything is in english, locale (french) is not correctly detected during installation, I guess. (regression, it used to works for a long time)

multiple parts windows or viewports crash the application ( Ok with the patch above with an older wine version)

Graphics windows is not correctly drawn if a background image is set (the application default). If a color backgroud is set, the app is really slow. With white background, the app runs at normal speed

sometime big slowdown occurs, specially during cdrawing circles. 10000x10000 bitmaps try to be allocated, causing lot of swapping, it may be related to the screen refresh mechanism, huge bitmaps are allocated using default values (uninitialised?) like if some messages are not processed in the right order.

3D operation extrude crashes the application. ( not a real crash, but a thread is blocked, and everything is freezed). It is really strange, the problem is related to the display of the extrusion UI, all of the other functions works !

opening an existing file works, but an error message is displayed many times ("incorrect function")

Saving files fails (no crash, but nothing saved) . Looks like storage (ole32 ?) implementation having problems.­

Workarounds

What was not tested

*** UPDATE ***

The version tested is NOT 0.54 ! I made a path mismatch compiling wine,  so all the comments here are related to 0.47 !

So 0.54 probably doesn't work, see bug 12582 http://bugs.winehq.org/show_bug.cgi?id=12582

**************
I tested it quite intensively, most the other features are OK.

Opening and modifying really complex models, with thousands of parts is working, so it is really disappointing to see 2 or 3 stupid bugs preventing any use !

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

There's an old patch for the OpenGL child windows problem http://www.winehq.org/pipermail/wine-devel/attachments/20070821/b0f56ecf/wine_glwin4-0001.bin That used to solve most of the multiple viewports and windows problems The patch has been partially included in wine, but that's not sufficient. Still rated garbage, as save and extrude bugs are preventing any normal use.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 9.04 "Jaunty" i386 (+ variants like Kubuntu)Jun 05 20091.1.22Yes Yes Bronzean anonymous user 
ShowUbuntu 8.04 "Hardy" i386 (+ variants like Kubuntu)Jul 12 20081.1.1Yes Yes Garbagedenis 
ShowUbuntu 8.04 "Hardy" i386 (+ variants like Kubuntu)May 13 20081.0-rc1Yes Yes Garbagedenis 
ShowUbuntu 7.10 "Gutsy" i386 (+ variants like Kubuntu)Apr 14 20080.9.59.Yes No Garbagedenis 
CurrentUbuntu 7.10 "Gutsy" i386 (+ variants like Kubuntu)Feb 17 20080.9.54.Yes Yes Garbagedenis 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back