WineHQ

Need for Speed: Hot Pursuit 2

The newest patch

Application Details:

Version: 242
License: Retail
URL:  
Votes: 1
Latest Rating: Platinum
Latest Wine Version Tested: 4.12.1

Maintainers: About Maintainership

No maintainers. Volunteer today!

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installer without any problems and changes.

Game Menus and Videos

Sound

Gameplay (including Network Play)

Joypad, (including ForceFeedback)

What does not

-

Workarounds

What was not tested

-

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Graphics with all set to max works perfectly, a little bit choppy, but still playable. Setting all to low helps a little bit, but its never ideally smooth on my 7300GT 128MB DDR3 (athlon 2000+ 1.66GHz, 768MB RAM) (but i think that its related to sime internal timers and functions, because on brother windowsxp sp2, radeon 9600 PRO, athlon 2GHz, 512MB RAM it doesnt works really smooth). But im sure, that it was working smooth many years ago when i had windows and gf4mx440. so maybe its some regression in windows, or crap ATI(Windows) driver ? With newest nvidia beta drivers(169.04) and antyalaising(for my 7300GT it impact really much on performance) set to "set by application", quality to 'quality' its working mostly smooth. Im using 242 patch, and no-cd patch.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowArch Linux x86_64Aug 12 20194.12.1Yes Yes NoPlatinumJohn Dildy 
ShowFedora 27 Beta x86_64Nov 28 20172.20Yes Yes NoPlatinumAlan Cai 
ShowDebian GNU/Linux 7.x "Wheezy"Apr 08 20121.5.1Yes Yes PlatinumProt 
ShowGentoo Linux x86_64Nov 15 20111.3.32Yes Yes Platinuman anonymous user 
ShowUbuntu 11.04 "Natty" amd64 (+ variants like Kubuntu)Jul 10 20111.3.24Yes Yes PlatinumInukaze 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

HowTo / Notes

HOWTO

I copied whole CD to HD, edit /autorun/autorun.cfg and changed EReg=1 and IEVersion=4.0 to EReg=0 and IEVersion=  and then start setup.exe, with that installation goes smooth:).

 Starting: CD must be in drive and then started his AutoRun.exe. (or you can use nocd patcher, but avoid running NfsHP2.exe directly !)
 Game menu: Cars, menu tree in Hot Pursuit, Championship, etc. not shown:(
 Playing: Very smooth, with some graphics problems (no tires), Special Efects and World Detail work with any settings, but Car Detail must be on low (with any other whole car not shown in the game)
 Sound: Perfect with OSS or Alsa, but with emulation (if your card doesnt has hardware mixer, because alsa dmix really sucks)

 Some messages from console, when in menu:
 fixme:d3d_texture:IWineD3DBaseTextureImpl_ApplyStateChanges >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glTexParameteri GL_TEXTURE_MAX_ANISOTROPY_EXT ... @ basetexture.c / 463

 and when actually start some race and play it, constantly give this:
fixme:d3d:get_src_and_opr Unhandled texture argWINED3DTA_SPECULAR

Howto from test results by smoko

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back