WineHQ
Category: Main Games Adventures Syberia 1.0.0.13 - SP3

Syberia

According to http://www.gamershell.com/news/6057.html -- The patch (SP3) is for the Canadian/European edition only, and it fixes a bug with overlapping voices. --

Application Details:

Version: 1.0.0.13 - SP3
License: Retail
URL:  
Votes: 0
Latest Rating: Gold
Latest Wine Version Tested: 1.5.25

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything works well but:

  • Ambient sounds are slightly crackling sometimes
  • Ambient sounds are too loud

What does not

  • Enabling AntiAliasing doesn't do anything
  • Adjusting sound settings doesn't do a thing

Workarounds

What was not tested

Playing the game to the end

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowLinux Mint 14 "Nadia" x86_64Apr 30 20131.5.25Yes Yes Goldan anonymous user 
ShowGentoo LinuxAug 25 20091.1.27Yes Yes GarbageLukas Matousek 
ShowUbuntu 8.10 "Intrepid" i386 (+ variants like Kubuntu)Mar 21 20091.1.17Yes Yes SilverJonathan 
CurrentUbuntu 8.10 "Intrepid" amd64 (+ variants like Kubuntu)Jan 19 20091.1.13Yes Yes GoldChristopher Lee Thomas 
ShowUbuntu 7.04 "Feisty" i386 (+ variants like Kubuntu)May 07 20070.9.36.Yes Yes GarbageJonas Aaberg 

Known Bugs

Bug # Description Status Resolution Other apps affected
21796 Syberia game can`t start normally NEW View

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

white screen
by Jakub Šenk on Saturday March 13th 2010, 7:26
Hi,

I have problem with running this game. I see only white background and buttons in menu. In the game I see only Kate and white background again. I have been testing wine 1.1.17, which has Silver rating and wine 1.1.39 (1.1.40 isnt at Mandriva repository yet), same problem.

Any ideas for resolving this problem, please?
Thanks ;)
About black screen
by Night Nord on Friday May 29th 2009, 16:58
I've encountered the same error currently ( black screen, but music playing ).
I've used any possible options but with no luck.

Solution was simple: I've downloaded "fixed" EXE from gamecopyworld. Now I have video, with Renderer opengl. native msvcrt and msvcp60, and Virtual Desktop enabled, but probably, all this is unnessessary, I'll test it some time later

Probably "black screen" is some kind of copy protection.
RE: About black screen
by Patrice Scolari on Monday June 22nd 2009, 18:32
You did it !

I'm dealing with 'Black screen' since ... many times ...

A simple no-CD solved my problem !
Now Syberia work perfectly.
( well well DRM again ... )
RE: About black screen
by Lukas Matousek on Monday August 24th 2009, 16:05
Hi.

I have similar problem - Black screen but music playing. If I wait a little, I get to menu, but I can see only buttons and cursor, when I click Options, then Options menu is visible, but on the background, there is Main menu still visible. By clicking on New game, I can see subtitles, but nothing else.

I have a NoCD patch (had some debugger error without it). I also have msvcrt and msvcp60 DLLs as native, Virtual Desktop, Syberia set on Win98. I have also changed some in regedit - HKCU/Doftware/Wine/AppDefaults/Syberia.exe/Direct3D/DirectDrawRenderer(string) to opengl.

Wine still keeps saying

fixme:d3d:stretch_rect_fbo >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION_EXT (0x506) from glBlitFramebuffer() @ device.c / 6510
fixme:d3d:context_attach_surface_fbo >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glFramebufferTexture2DEXT() @ context.c / 267
fixme:d3d:context_attach_depth_stencil_fbo >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from glFramebufferTexture2DEXT() @ context.c / 245

all around...

Do you have any ideas what should I try?

Any help is welcome. Thanks
Missing Textures (White screen)
by mad cat on Monday February 9th 2009, 15:10
I have the following problem with the game:
It starts and then the screen is white,the movies don't show up and the textures on the menus are missing.When I start a new game everything is white and I can only see the Character(not the walls or anything else.
Here is some output:


@ nvidia_texture_shader.c / 448
fixme:d3d:set_tex_op_nvrc >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from set_tex_op_nvrc()
@ nvidia_texture_shader.c / 448
fixme:d3d:set_tex_op_nvrc >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from set_tex_op_nvrc()
@ nvidia_texture_shader.c / 448
fixme:d3d:set_tex_op_nvrc >>>>>>>>>>>>>>>>> GL_INVALID_ENUM (0x500) from set_tex_op_nvrc()


Is there any solution for this?
RE: Missing Textures (White screen)
by Patrice Scolari on Monday June 22nd 2009, 18:38
Was just testing the " no-CD " solution given by Night Nord to bypass the Black Screen problem and was face off a ... White screen instead with somes buttons and no decors ingame :

Just checked Pixel Shaders , Vertex Shaders and Virtual Desktop in Winecfg and now everything is working ;)

by Andrew on Monday May 5th 2008, 5:58
Sometimes can help changinc on /etc/xorg.conf
Section "Screen"
Defaultdepth from 32 or 24 on 16 !!!But i have some truble whith this changinc on ATI graphic gard
EndSection
Truble: my monitor BenQ FP71G+ can't work on this mode
Everything is black
by Patrice Scolari on Monday April 21st 2008, 6:21
Just testing Syberia on Wine 0.9.60

Remember me the old days : black screen with musics

Here's all my errors message :

wine Syberia.exe
fixme:msvcrt:msvcrt_get_flags :unknown flag w not supported
fixme:win:EnumDisplayDevicesW ((null),0,0x32ee80,0x00000000), stub!
fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
err:d3d:CreateContext HDC=0x380 is already set to iPixelFormat=11 and OpenGL doesn't allow changes!
fixme:msvcrt:msvcrt_get_flags :unknown flag w not supported

Trying a native Msvcrt.dll , regsitry keys & many tweaks in Winecfg doesn't help.
If anyone have an idea on what happen , i've never seen the " iPixelFormat " line before.
Tests results so far..
by Jonas Aaberg on Wednesday May 9th 2007, 12:57
I have an ATI Mobility X300 and uses ATI properitery drivers.
These drivers does not work in 16 bpp without the
--
Option "PseudoColorVisuals" "on"
--
set in your xorg.conf.
Syberia outputs a debug log (debug.log) which says among others:
--
Selected render driver description is: 'DirectDraw HAL (T&L DX7)'
Creating full-screen render context (800x600x16)
--
Manually editing the config file to be 32 bit colour does not
change anything really. (I know that in the game you can choose between 16 and 32 bit colours)
Everything looks fine in the Syberia log except for occational
--
SetGammaInternal: Unable to get gamma (alt-tabed out?)
--
Switching Vertex and pixel shaders on and off does not change antyhing.
Downloading and adding native "msvcrt.dll" reduces the number of
fixme and warnings printed by wine.

With 16bpp mode and X in 24 " WINEDEBUG=warn+dll wine Syberia.exe" says:
--
fixme:win:WIN_CreateWindowEx Parent is HWND_MESSAGE
fixme:d3d:IWineD3DDeviceImpl_GetAvailableTextureMem (0x1a1998) : stub, simulating 64MB for now, returning 64MB left
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x190ba8)->((nil),00000008)
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x190ba8)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x190ba8)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x1a15d8)->(0x20024,00000008)
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x1a15d8)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x1b7950)->(0x20024,00001417)
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel DirectDraw is not thread safe yet
fixme:d3d:IWineD3DDeviceImpl_SetMultithreaded No thread safety in wined3d yet
fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 16
err:dsound:DSOUND_MixOne underrun on sound buffer 0x1181b08
--
RE: Tests results so far..
by Patrice Scolari on Tuesday July 17th 2007, 4:38
Exactly the same messages & black screen on Wine 0.9.40 , we can heard the music played & can click on the menu to play the game ( on a black screen , its funny : a new " alone in the dark ? " ^^ ) BUT :

When i tell to Wine to start in fullscreen mode and type an ALT+TAB , i can see the game !
But another problem , there's no animation , look like a screenshot , i need to type ALT+TAB every seconds to make myself the games's animation ( another funny thing ^^ )
Perhaps an option in the Xorg.conf ?

I ran on Zenwalk 4.6.1 on AMD64 3000+ & 7600GT on 100.14.11 driver.

ps : sorry for my english , hope you understand me :)
RE: Tests results so far..
by Jonas Aaberg on Tuesday July 17th 2007, 13:16
For me, in wine 0.9.42, everything is still black when alt-tabbing.
7600GT sounds like an NVIDIA card, right? I've this far
assumed that the bug is related to ATI driver and/or the
mobility x300 that I have.
But if you have an NVIDIA card, maybe it is some magic
xorg.conf setting that should be changed.
(I'm running kubuntu 7.04)
RE: Tests results so far..
by Jonas Aaberg on Tuesday July 17th 2007, 13:25
Sorry, I run wine 0.9.41.
RE: Tests results so far..
by Patrice Scolari on Tuesday July 17th 2007, 17:04
I've seen many thing about DDRAW.DLL & D3D7 games
I'll try to find a dll patched ( regarding to Diablo for exemple )
Perhaps the way to play to this fantastic game :)
RE: Tests results so far..
by Jonas Aaberg on Wednesday July 18th 2007, 12:07
The patch forces you into the GDI mode and Syberia does only
shows up an error box saying that the 3D engine can't be started
and then quits. Anyway, I manually
applied the non-GID forcing part of the patch to wine 0.9.41
and tested to run Syberia with both GDI and OpenGL
as renderer. No luck :-( Syberia crashed at start-up in OpenGL
mode. Which makes sense considering the nature of the patch.
Solved !
by Patrice Scolari on Wednesday October 24th 2007, 22:01
OK ! Solve for me ! ( wine 0.9.47 )

After tried many & many options with differents combinaisons : it work !

Set in your HKCU/Software/wine/Direct3D your DirectDrawRenderer string to opengl. ( GDI give me the same message as your post )

Then in your Winecfg :
- Set to Windows 98
- & uncheck all options in your Screen -> Windows Parameters
( no virtual desktop & others ... )

He works in fullscreen without any other options.
( my screen goes black if i check the third 3 options , running in windowed mode )

Hope that help you :)

ps : the " quit " menu result in a black screen so i quit with ALT+TAB grabbing my terminal & close it.
Back