WineHQ

The Lord of the Rings: The Battle for Middle-Earth II

It's the normal version when installing the game.

Application Details:

Version: 1.00
License: Retail
URL: http://www.ea.com/official/lor...
Votes: 0
Latest Rating: Platinum
Latest Wine Version Tested: 3.0.1

Maintainers: About Maintainership

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Installing, changing settings, playing (only single player skirmish tested!). But above all - THE CURSOR! Partly at least.


What does not

Some shapes are white - setting UseGLSL to disabled fixes the problem.

The cursor is back, but it's not perfect. It disappears when you hover over clickable things like units or buildings. As long as such an object is selected the cursor is invisible. Anyway, the game is now playable.

Workarounds

What was not tested

As I only tested single player skirmish I can't say if other parts of the game work as they should.

I haven't tried updating the game either.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

Because I'm lazy I installed the game through PlayOnLinux. Except for UseGLSL I also set OffscreenRenderingMode to fbo (mostly for the first version of the game which I have installed in the same prefix) and VideoMemorySize according to my gpu.

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 18.04 "Bionic" amd64 (+variants like Kubuntu)May 20 20183.0.1Yes Yes NoPlatinumLuke 
ShowUbuntu 10.10 "Maverick" amd64 (+ variants like Kubuntu)Mar 23 20111.3.12Yes Yes Platinuman anonymous user 
CurrentFedora 9Nov 11 20081.1.8Yes Yes GoldPrzemek 
ShowFedora 7 x86_64Jul 31 20070.9.42.Yes Yes GoldNikolay Vladimirov 

Known Bugs

Bug # Description Status Resolution Other apps affected

Show all bugs

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

installation
by Vit Hrachovy on Thursday June 21st 2007, 3:22
Installation should work in 0.9.39 (should display the white window with yellow clickable text - "Install" cca at 3rd dialog). Don't forget to set UseGLSL registry key to 'enabled' to use OpenGL 3D graphics. Depending on Your 3D drivers You may see only partial render.
Back