WineHQ

Star Wars - Battlefront II

Battlefront + 1.1 update patch

Application Details:

Version: 1.1
License: Retail
URL: http://lucasarts.com/games/swb...
Votes: 3
Latest Rating: Silver
Latest Wine Version Tested: 1.9.0

Maintainers: About Maintainership

No maintainers. Volunteer today!

Free Download 1.1 Update patch

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

I have used the version from the "Star Wars Fan Favorites I", a 2 dvd set with Battlefront I & II and Republic Commando.  It installs version 1.1 (so 1.1 patch is not needed). Below are the problems I've had:

  • (bug #27691) When hardware shaders are enabled, vegetation polygons are not rendered with the correct alpha layer, causing them to be fully opaque instead of opaque only where the grass, leaves, etc are drawn and transparent on the rest.  This causes lower visibility than normal on Felucia and Dagobah making them noticeably more difficult.  I have found a few polys like this on Coruscant as well, but they are only in decorations. (This may be an NVidia issue and perhaps even a GeForce 260 specific issue)
  • (bug #29582) Load levels is extremely slow (1:45 on a pretty fast machine).  So much so that multiplayer was not possible as the host disconnected me by the time I was finished loading (presumably because it figured I crashed).

Aside from the above, actual game play is flawless with graphics maxed, frame-rate is supurb.  There is a slight lag for the first 500mS after the level loads, but that may happen on Windows as well.

 

Installation worked out of the box and gameplay without no-cd crack works both when the dvd is in the drive (and I set a CD-ROM drive to it in winecfg) as well as an iso image of said dvd, so I guess the secure-rom stuff is now working fully in Wine, hurray!

What does not

Multiplayer is broken due to servers kicking me when taking so long to load.

Workarounds

What was not tested

Did not test using GameSpy.
I have not attempted to patch it to 1.2 yet.

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

The fact that slow loading keeps you out of multiplayer is all that's holding this back from a gold rating. Hardware: AMD Phenom 9850 (Quad-Core) 8GB RAM NVidia GTX 260 SC 896MB

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowUbuntu 15.10 "Wily" amd64 (+ variants like Kubuntu)Jan 10 20161.9.0Yes Yes SilverImperatorS79 
ShowUbuntu 14.04 "Trusty" i386 (+ variants like Kubuntu)Apr 24 20141.6.1Yes Yes Silveran anonymous user 
ShowManjaro LinuxMay 02 20131.5.29Yes Yes BronzeMatthew O. 
ShowLinux Mint 12 "Lisa" x86_64Feb 21 20121.3.36Yes Yes Goldan anonymous user 
CurrentGentoo Linux x86_64Jan 14 20121.3.36Yes Yes SilverDaniel Santos 

Known Bugs

Bug # Description Status Resolution Other apps affected
29582 Star Wars Battlefront (I and II) "Loading" screen very slow. NEW View

Show all bugs

Comments

Comments Disabled

Comments for this application have been disabled because there are no maintainers.
Back