WineHQ

The Settlers II: 10th Anniversary

Application Details:

Version: 1.x
License: Retail
URL: http://www.thesettlers.com/uk/...
Votes: 6
Latest Rating: Gold
Latest Wine Version Tested: 1.9.3

Maintainers: About Maintainership

Free Download Czech patches

Test Results

Old test results
The test results you have selected are very old and may not represent the current state of Wine.
Selected Test Results

What works

Everything is working.

I didn't need a nocd patch. It worked out of the box without any errors. I don't know what could be better so for me it's Platinum.

What does not

Workarounds

What was not tested

Network Play

Hardware tested

Graphics:

  • GPU:
  • Driver:

Additional Comments

selected in Test Results table below
Operating systemTest dateWine versionInstalls?Runs?Used
Workaround?
RatingSubmitter
ShowArch Linux x86_64Feb 20 20161.9.3Yes Yes Goldan anonymous user 
ShowLinux Mint 17.2 "Rafaela" x86-64Sep 13 20151.6.2Yes Yes Platinuman anonymous user 
ShowUbuntu 13.04 "Raring" amd64 (+ variants like Kubuntu)Jul 24 20131.6Yes Yes PlatinumAdrian Kalla 
CurrentGentoo Linux x86_64Mar 20 20131.5.25Yes Yes Platinuman anonymous user 
ShowMac OS X 10.7 "Lion"Nov 24 20121.5.18Yes Yes Goldan anonymous user 

Known Bugs

Bug # Description Status Resolution Other apps affected
44546 The Settlers II: 10th Anniversary runs very slow when CSMT enabled NEW View

Show all bugs

HowTo / Notes

HOWTO

This Howto will tell you, how you can play "The Settlers 2" with WIne under Linux.....

 

  1. Open a Console and Enter "winecfg"
  2. Change to the Grafics Tab and Uncheck "Allow Window Manager to Control the Mouse"....
  3. Click on "OK"
  4. Mount the Game CD/DVD and start the Installer with "wine Setup.exe"
  5. Install the Game.....
  6. Than put the Files: d3dx9_29.dll and msvcr71.dll download them from dll-flies.com
  7. Unpack this Files and Copy them to "/home/YOURNAME/.wine/drive_c/windows/system32"
  8. Open a Console and Enter "wineboot"
  9. If you want to Play Online please Download and Install the Newsest Patch...
  10. After that you need a NoCD Patch from "special websites", copy this Patch into
    "......Ubisoft/Funatics/Die Siedler II - Die nächste Generation/bin"
  11. Start the Game in the BIN Folder in a Console with Wine....
  12. Enjoy the Game!

Known Problems:

---> The Water looks crazy.... I hope it will fixed soon...
---> The Performance is very good on Nvidia Cards... ATI is a little bit Slower!

Game crashes at the same point

If your game crashes always at the same point even though you tried it multiple times with load/save, you can try the following:

  • Zoom in to 1 level before maximal zoom.
  • Remove fast motion (set speed to 1x).

Comments

The following comments are owned by whoever posted them. WineHQ is not responsible for what they say.

Slow Performance with intel graphics and CSMT enabled with vikings (de: Wikinger) extension
by Jens on Friday January 4th 2019, 2:32
I just found due to the related bug ticket and also the general performance hint page of wine that I had to disable CSMT to make Viking extension work for me. I still could start normal Settler 2 without performance impact.
To disable it you need to change registry entry
wiki.winehq.org/Useful_Registry_Keys

General performance hint page
wiki.winehq.org/Performance
Game will not launch
by Tom on Sunday November 27th 2011, 10:19
All,

I have followed the how-to, but still can not get the game to launch. When I run "Wine S2DNG.exe", it will resize my screen, have a small window in the top left briefly with version number of the game, and then just drop. Here is the last couple of lines of the console that come up as well, don't know if that might help with troubleshooting.


fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:d3dx:D3DXCreateTextureFromFileInMemoryEx (0x19e6a0, 0x16bef60, 4140, 4294967295, 4294967295, 1, 0, fffffffd, 1, 2, 2, 0, (nil), (nil), 0x16be95c): stub
fixme:d3dx:D3DXCreateFontIndirectW (0x19e6a0, 0x132f640, 0x16be9c0): stub
wine: Call from 0x7b8373a2 to unimplemented function d3dx9_36.dll.D3DXCreateCubeTexture, aborting
fixme:winmm:MMDRV_Exit Closing while ll-driver open
err:mmtime:TIME_MMTimeStop Timer still active?!
tom@nav-laptop:~/.wine/dosdevices/c:/Program Files/Ubisoft/Funatics/The Settlers II - 10th Anniversary/bin$ wine S2DNG.exe
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x146ed8,0x146df8): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x132f0b4,0x00000000), stub!
fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:d3dx:D3DXCreateTextureFromFileInMemoryEx (0x19dd40, 0x16bef60, 4140, 4294967295, 4294967295, 1, 0, fffffffd, 1, 2, 2, 0, (nil), (nil), 0x16be95c): stub
fixme:d3dx:D3DXCreateFontIndirectW (0x19dd40, 0x132f640, 0x16be9c0): stub
wine: Call from 0x7b8373a2 to unimplemented function d3dx9_36.dll.D3DXCreateCubeTexture, aborting
fixme:winmm:MMDRV_Exit Closing while ll-driver open
err:mmtime:TIME_MMTimeStop Timer still active?!
RE: Game will not launch
by pat on Saturday May 3rd 2014, 4:24
My game crashed after resizing the screen, too. It worked after installing d3dx9_36 with winetricks.

Error was:

fixme:d3dcompiler:compile_shader Compilation target "fx_2_0" not yet supported
fixme:d3dx:d3dx9_effect_compiler_init Failed to parse effect, hr 0x8876086c.

However, after playing the intro video I get another error messagebox with shadow.fx, ID3DXEffectCompiler and can only abort
RE: Game will not launch
by Basti on Saturday May 3rd 2014, 7:41
I have the same problem. You can "Ignore" the errors and reach the main menu, however trying to start a game will cause a crash.
Problem with shadowing
by Robin on Thursday November 10th 2011, 17:34
I have installed the game and it runs ok. However when I first booted the game it looked like it couldn't find the textures, all the trees and a few other things were completely black. I played about with some of the settings and found that if I go into the game engine settings and turned the 'shadow detail' right down the trees etc display correctly.

Has anyone seen this before, could anyone suggest how I might fix this?

Im running wine 1.2.2 on Ubuntu 11.04
RE: Problem with shadowing
by Vit Hrachovy on Friday November 11th 2011, 3:35
Try latest Wine 1.3.32 and if the problem persists, please submit a bug.
RE: Problem with shadowing
by Robin on Saturday December 3rd 2011, 7:08
Upgrading to wine 1.3.34 solved the problems, thanks
fog bug
by Rion on Saturday May 29th 2010, 15:49
i had this weird bug with fog of war. but after installing wine-1.2-rc2 game works fine =)
fglrx 10.1 + wine 1.1.38
by Szymon on Sunday March 7th 2010, 9:23
I had some pretty nasty artifacts when using fglrx 10.1 + wine 1.1.38 on ATI Radeon 4330, switching to older version of wine (1.1.37) fixed this issue. I am using alsa sound with wine and the audio sometime lags but not always, don't know why :/. The game is fully functional with or without the vikings addon using wine 1.1.37.
Game works awsome with no shadow detail.
by jim on Friday August 15th 2008, 22:25
Hey, I found if you select the graphics to low the game looks perfect. Then I figured out the shadow detail is buggering the game up by making the guys go green, ect but if you turn it off and the rest too high then have a custom graphic lay out the game works awsome. Im using a nvidia gforce 7600 512 mb fedora core 8.
RE: Game works awsome with no shadow detail.
by jim on Saturday August 16th 2008, 0:11
Turn off Shadow Detail, Quality and Shader Quality, for better game experience....
RE: Game works awsome with no shadow detail.
by ethnoe on Saturday August 16th 2008, 5:05
You were right, it works, althought I could swore I have tried changing all the setttings to minimum and run the game before I posted my problem here.

Anyway - thanks :)
Fog of War
by Andreas Guse on Thursday August 7th 2008, 4:43
hey.

Same problem over here. The game plays just fine - but in the upper right corner only.

Graphic Controller (Intel Onboard / Dell Inspiron 6400):
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

OS: Ubuntu hardy.

Wine from Ubuntu repos:
wine --version
wine-1.0

Is there a fix for this problem yet?

cheers,
mene
Crazy colors
by ethnoe on Sunday July 20th 2008, 5:24
Game runs smoothly for me (polish edition with latest available patch), but colors are mixed up - settlers have green skin, buildings are too yellow. The terrain and background objects are ok. Any suggestions how to fix this issue?
Fog of war, still no solution?
by Christoffer Tombre on Sunday May 4th 2008, 11:53
I have the all known fog of war problem. It's only the upper right of the screen that shows anything at all...

Are there still no solution for this?

Don't bother telling me to use the ShowMeTheWorld cheat, as I have tried this already!
RE: Fog of war, still no solution?
by Mirko Dokic on Sunday May 4th 2008, 14:23
What's the brand of your gfx card?
RE: Fog of war, still no solution?
by Christoffer Tombre on Monday May 5th 2008, 6:14
It's a Intel 82915GM onboard graphics card.
RE: Fog of war, still no solution?
by Mirko Dokic on Thursday May 8th 2008, 5:50
Have you installed all intel graphics drivers? (sudo apt-get install xserver-xorg-video-intel)
RE: Fog of war, still no solution?
by Marcus Klemm on Sunday May 25th 2008, 3:04
I have exactly the same problem using ATI's fglrx driver.
RE: Fog of war, still no solution?
by scheich on Monday June 30th 2008, 6:26
First Windows Game that runs under wine, but not under Windows XP. lol
But I have that fog of war. With the cheat I only get this small area upper right. Unplayabel... :(
Running Debian Testing with Wine 1.1 and INTEL 915 xorgdriver installed.

Please someone know how to solve this problem?

greetz, scheich
RE: Fog of war, still no solution?
by scheich on Monday June 30th 2008, 6:27
First Windows Game that runs under wine, but not under Windows XP. lol
But I have that fog of war. With the cheat I only get this small area upper right. Unplayabel... :(
Running Debian Testing with Wine 1.1 and INTEL 915 xorgdriver installed.

Please someone know how to solve this problem?

greetz, scheich
RE: Fog of war, still no solution?
by michstress on Wednesday November 12th 2008, 15:50
Same Problem here, after typing ShowMeTheWorld I see the upper right corner, that's it. Running on an Asus Eee PC900a that is 1024x600 resoution with the glxinfo providing:

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 945GME 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.3-rc2

wine-1.1.8 on ubuntu hardy heron

Any ideas? Anyone?
fixme:winmm:MMDRV_Exit Closing while ll-driver open
by Mirko Dokic on Sunday April 6th 2008, 14:45
If it crashes randomly saying

fixme:winmm:MMDRV_Exit Closing while ll-driver open

then go to winecfg/Audio and set DirectSound Hardware Acceleration to Emulation.

After that it never crashed for me again.
very bad on 865G
by event on Saturday March 15th 2008, 8:23
Hello,

I have some mess with Gentoo and Intel 865G graphics. It installs and runs. But when it comes to a game half of the screen is black and on the other half there is some color mess instead of good picture. Looks like something with OGL. Checked glxinfo - looks fine. At least direct rendering is enabled.
Could someone help?

Thanks in advance.
Installation
by Pascal Dürsteler on Sunday February 3rd 2008, 3:33
I'm not able to install the game because the installer says "invalid cd key" before I could make any inputs!

Anyone had this issue, too?

(See Bug 11413)
RE: Installation
by Stefan on Thursday January 8th 2009, 9:57
same problem here. did you get a solution to this "invalid cd key" problem?
Fog of war on three thirds of the screen
by Dominik on Tuesday January 15th 2008, 7:03
Hy,
after I star tthe game in normal mode there is fog of war on the whole screen. If I use the "showmetheworl" cheat I get the normal screen in the upper left quadrand of the screen, on all other three quadrants the fog of war remains.

I got a Intel 945GM using Debian unstable and wine 0.9.53.

Can somebody help me?

Thanks
TO
RE: Fog of war on three thirds of the screen
by Dominik on Tuesday January 15th 2008, 7:29
Here are some screenshots:
1. all fog of war:
www.dbruhn.de/div/fehler_eins.jpg

2. One quater good:
www.dbruhn.de/div/fehler_zwei.jpg
Editor
by Michael Kurz on Thursday September 20th 2007, 11:14
Does the Editor for someone work? When i try to start it it dies with:
wine: Unhandled page fault on read access to 0x00000100 at address 0x7d7054 (thread 0009), starting debugger...

followed by a stack dump / Backtrace

I'm on AMD64, and the game runs just fine
Mouse & Sound problems
by Georg Hennig on Thursday September 6th 2007, 8:12
Hi,
I would like to write a few comments:

- The installation issue can be solved by pressing "Alt+Tab"

- Here no need to download msvcr71.dll, it's inside program's bin directory

- No need to download d3dx9_29.dll, it's inside Support/DirectX/Feb2006_d3dx9_29_x86.cab on the CD (you'll need cabextract and then copy the dll to system32 folder)

- Sound "stutters", you can get around this by "nice -20 wine ..." (stutter frequency then is only once every few seconds or so)

- Mouse pointer flickers (in the menu only when moved, during gameplay all the time). I have no solution for this one. Does anyone else have this problem?

Thanks
Georg
RE: Mouse & Sound problems
by Georg Hennig on Thursday September 6th 2007, 8:13
I forgot: wine 0.9.44 on Gentoo.
No fog of war problems, btw.
Fog of War Updates
by Nikita on Wednesday July 18th 2007, 10:46
With Wine 0.9.40 and GeForce 5200, fog of war updates only in south west quadrant of the screen. But you can remove fog of war completely. to do this, press enter, and type "ShowMeTheWorld", and press enter again.
RE: Fog of War Updates
by Smith on Saturday August 11th 2007, 0:37
oh, tnx... this problem i had, perfect solution ^^
Playing
by Timii on Wednesday July 4th 2007, 8:29
I did get game it self working quite well. Everything else works just fine, but graphics have something wrong. I get this error when I try play the game. It shows like almost everywhere is "fog of war" on and it doesn't disappear. Only little area shows right.

fixme:d3d:handleStreams Tangent and binormal bump mapping is only valid with vertex shaders
fixme:d3d_texture:IWineD3DTextureImpl_ApplyStateChanges Non-power2 texture being used with generated texture coords

Do anybody know how to fix this.

ps.

I think this happens because I have ATI 9800 pro.
RE: Playing
by Nikita on Wednesday July 18th 2007, 10:58
No. I've the same thing on my nvidia card. type "ShowMeTheWorld" to remove FOW.

by Christoph Schwerdtfeger on Thursday February 1st 2007, 12:50
I don't have a nocd crack for the original game - I own the original and the 10th anniversary edition. Didn't find a nocd for settlersII, only for the anniversay remake, have to search a bit more I think.

Now SettlersII anniversary seems to work, but it doesn't work because I own an ATI card...

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 146 (ATIFGLRXDRI)
Minor opcode of failed request: 1 ()
Value in failed request: 0x5600059
Serial number of failed request: 528
Current serial number in output stream: 528
RE:
by Wingnux on Saturday July 14th 2007, 15:01
Got the same error here =/
Installation
by Christoph Schwerdtfeger on Tuesday January 30th 2007, 16:05
How did you get the installation working?

The installation switches to fullscreen after entering the serial number but only displays the background image. I can't access the dialogue to choose the directory and continue the installation.

I'm using wine-0.9.29 on a Debian "testing" machine using a 2.6.18-3-amd64 kernel.

Any help will be appreciated.
RE: Installation
by Mirko Guenther on Wednesday January 31st 2007, 14:02
I use the windowmode. I don't try the installation at wine-0.9.29 but with wine-0.9.30 it works.
RE: Installation
by Christoph Schwerdtfeger on Wednesday January 31st 2007, 16:49
Ok, I disabled the option to let the window manager control the windows and then I could see the installation window and install the game, but I just can't get it working.

Neither the new game nor the old version of Settlers II (German) works for me.

I even tried a NoCD crack but still now luck:

# wine Siedler2.exe
Invoking /usr/lib/wine/wine.bin Siedler2.exe ...
Wine failed with return code 1

Is there anything I need to configure/install?
RE: Installation
by Mirko Guenther on Thursday February 1st 2007, 2:16
Do you have made the changes from the HowTo of the Demo?

The old game has also a copy-protection. If you don't have a NoCd-Crack it will not work.
RE: Installation
by Smith on Saturday August 11th 2007, 0:35
press enter three times in a row, than wait for installation and when cdrom will no working press enter one more time:) but it will install acrobat reader at the end..:P but it works
Back